Reduced email delivery timing
Incident Report for SoundViz
Resolved
This incident has been resolved.
Posted over 2 years ago. Oct 22, 2016 - 00:32 PDT
Identified
Due to an active incident with an upstream provider, we are experiencing slower than average email sending. We are monitoring the situation and will update as we get more information.
Posted over 2 years ago. Oct 21, 2016 - 15:13 PDT
This incident affected: SoundViz.com.