Address submission errors
Incident Report for SoundViz
Resolved
We have identified and resolved the address issue. Thank you for you patience.
Posted over 3 years ago. Mar 21, 2016 - 15:15 PDT
Monitoring
We have identified the issue and applied a fix. If you continue to see any errors around address submission, please email hello@soundviz.com immediately.
Posted over 3 years ago. Mar 21, 2016 - 12:04 PDT
Investigating
We are currently investigating failed address submissions on soundviz.com.

If you have received a 503 error when submitting your shipping address, you may try refreshing the page to verify it was created. If that does not work, please contact us at hello@soundviz.com
Posted over 3 years ago. Mar 21, 2016 - 10:46 PDT